I'm usually super Nazi about the site being fast...

Discussion in 'Encyclopedia Dramatica Collaboration' started by Edgeworth, Jan 12, 2012.

  1. Edgeworth

    Edgeworth
    Expand Collapse
    Systems Administrator

    Joined:
    Jul 14, 2011
    Messages:
    1,266
    Occupation:
    Web Developer/Systems Administrator
    We're actually getting so much traffic that I believe the stats tracker crashed for a bit, but look at this...
    [​IMG]

    That's half a million requests in the past hour :O

    Amazingly enough, the jew golds that you donated to us helps us stay up and not die in a fire. Lol.
     
  2. TheBrickBalls

    TheBrickBalls
    Expand Collapse
    Girlvinyl

    Joined:
    Jul 16, 2011
    Messages:
    2,017
    Occupation:
    Gay Nigger
    Home Page:
    Is that for the wiki and the forums? How big is .ch getting compared to how big .com was in the past?

    Edit: Someone's launched a pointless attack on the site again like last time.

    [​IMG]
     
  3. I_Cant

    I_Cant
    Expand Collapse
    EDF Elite

    Joined:
    Jul 15, 2011
    Messages:
    2,354
    the site does seem to be acting weird, like the server is under heavy load.

    strangely enough, I started noticing slow load times at the same time as Zaiger put up the script for cycling the banners
     
  4. Edgeworth

    Edgeworth
    Expand Collapse
    Systems Administrator

    Joined:
    Jul 14, 2011
    Messages:
    1,266
    Occupation:
    Web Developer/Systems Administrator
    Has nothing to do with the banners. It just looks like we're getting a lot of traffic (about a quarter million requests since I posted this thread) on the main website. The forums are fine :O.

    The attack actually is completely owning our advertisement provider -- chronic ads --. Their website was inaccessible until I removed the advertisement code from the the wiki.
     
  5. I_Cant

    I_Cant
    Expand Collapse
    EDF Elite

    Joined:
    Jul 15, 2011
    Messages:
    2,354
    I thought the shitload of reverse-proxies was supposed to dampen the effects of attacks!

    and from my perspective the Forums are loading slower than the wiki
     
  6. I_Cant

    I_Cant
    Expand Collapse
    EDF Elite

    Joined:
    Jul 15, 2011
    Messages:
    2,354
    huh, lag's gone down. did you do anything?
     
  7. Edgeworth

    Edgeworth
    Expand Collapse
    Systems Administrator

    Joined:
    Jul 14, 2011
    Messages:
    1,266
    Occupation:
    Web Developer/Systems Administrator
    No. Not this many requests :O.

    We've served around a million requests now :O
     
  8. I_Cant

    I_Cant
    Expand Collapse
    EDF Elite

    Joined:
    Jul 15, 2011
    Messages:
    2,354
    the lag seems to be cycling on and off.

    are they hitting Cloudflare or are they attacking the server behind it?
     
  9. zaiger

    zaiger
    Expand Collapse
    2017 Faggot Of The Year

    Joined:
    Jul 14, 2011
    Messages:
    9,343
    Occupation:
    Dramaticorp
    Home Page:
    We are just as big/maybe a little bigger than .com was.

    I don't have their numbers but we get a lot of traffic, at least on the Wiki we do. I don't know why the forums aren't busier than they are. They are still busy, but EDF doesn't get anywhere near the traffic that the Wiki does.
     
  10. I_Cant

    I_Cant
    Expand Collapse
    EDF Elite

    Joined:
    Jul 15, 2011
    Messages:
    2,354
    there probably isn't quite as much data on the server as there was with .com, considering that we don't have all of those previous versions of pages and files.
     
  11. Edgeworth

    Edgeworth
    Expand Collapse
    Systems Administrator

    Joined:
    Jul 14, 2011
    Messages:
    1,266
    Occupation:
    Web Developer/Systems Administrator
    It isn't DDoS. It's going through cloudflare.
     
  12. I_Cant

    I_Cant
    Expand Collapse
    EDF Elite

    Joined:
    Jul 15, 2011
    Messages:
    2,354
    this isn't a DDOS? where's all the traffic coming from then? this can't be normal
     
  13. Edgeworth

    Edgeworth
    Expand Collapse
    Systems Administrator

    Joined:
    Jul 14, 2011
    Messages:
    1,266
    Occupation:
    Web Developer/Systems Administrator
    Hmm. Let me rephrase. It's not a TCP/UDP/SYN flood, it's just a bunch of http requests to the wiki.
     
  14. I_Cant

    I_Cant
    Expand Collapse
    EDF Elite

    Joined:
    Jul 15, 2011
    Messages:
    2,354
    alright, are they triggering the search function or just going straight to pages? and do you have any means of determining where it's coming from?
     
  15. zaiger

    zaiger
    Expand Collapse
    2017 Faggot Of The Year

    Joined:
    Jul 14, 2011
    Messages:
    9,343
    Occupation:
    Dramaticorp
    Home Page:
    I meant traffic. I have no idea how much ED.com was on disk
     
  16. zaiger

    zaiger
    Expand Collapse
    2017 Faggot Of The Year

    Joined:
    Jul 14, 2011
    Messages:
    9,343
    Occupation:
    Dramaticorp
    Home Page:
    I am getting server errors now.
     
  17. I_Cant

    I_Cant
    Expand Collapse
    EDF Elite

    Joined:
    Jul 15, 2011
    Messages:
    2,354
    I've been getting cloudflare errors for the last hour or so, guessing it's just timeouts
     
  18. Edgeworth

    Edgeworth
    Expand Collapse
    Systems Administrator

    Joined:
    Jul 14, 2011
    Messages:
    1,266
    Occupation:
    Web Developer/Systems Administrator
    Yeah. Nothing much we can do :x Gotta ride it out.
     
  19. CallMeMaggot

    CallMeMaggot
    Expand Collapse
    Girlvinyl

    Joined:
    Jul 15, 2011
    Messages:
    14,471
    Home Page:
    lol

    [​IMG]
     
  20. I_Cant

    I_Cant
    Expand Collapse
    EDF Elite

    Joined:
    Jul 15, 2011
    Messages:
    2,354
    CallMeMaggot's computer is part of a botnet. lol
     
  21. CallMeMaggot

    CallMeMaggot
    Expand Collapse
    Girlvinyl

    Joined:
    Jul 15, 2011
    Messages:
    14,471
    Home Page:
    nope, I'm clean, just scanned
     
  22. I_Cant

    I_Cant
    Expand Collapse
    EDF Elite

    Joined:
    Jul 15, 2011
    Messages:
    2,354
    hmm, wonder why it said that...

    although scanners don't always detect the latest versions of things.
     
  23. CallMeMaggot

    CallMeMaggot
    Expand Collapse
    Girlvinyl

    Joined:
    Jul 15, 2011
    Messages:
    14,471
    Home Page:
    just passed ccleaner and spybot, firewall ok, I'll update AVG anyways

    Chrome still gives me same shit as FF8...

    ???
     
  24. CallMeMaggot

    CallMeMaggot
    Expand Collapse
    Girlvinyl

    Joined:
    Jul 15, 2011
    Messages:
    14,471
    Home Page:
    I also keep getting messages of high memory use (408 M last time), in Chrome and FF too
     
  25. Edgeworth

    Edgeworth
    Expand Collapse
    Systems Administrator

    Joined:
    Jul 14, 2011
    Messages:
    1,266
    Occupation:
    Web Developer/Systems Administrator
    I turned security up to really high to try and get it to filter the bots :x
     
  26. I_Cant

    I_Cant
    Expand Collapse
    EDF Elite

    Joined:
    Jul 15, 2011
    Messages:
    2,354
    ah, that explains it.